Website currently unavailable

Incident Report for Small Improvements

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 09:23 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Dec 05, 2025 - 09:13 UTC

Identified

The Small Improvements website is currently unavailable due to a major outage.

One of our third party providers is experiencing problems which has lead to the Small Improvements website being unavailable. We're working on resolving the issue.
Posted Dec 05, 2025 - 08:45 UTC
This incident affected: Website.