Investigating Outage on [EU|US] Servers
Incident Report for Small Improvements
Resolved
Google has indicated that service interruptions have been fully resolved and clarified they will conduct an internal investigation of this issue and make appropriate improvements to their systems to help prevent or minimize future recurrence.

Please reach out to support@small-improvements with any questions!
Posted Jul 17, 2018 - 20:28 UTC
Monitoring
It appears that Google has restored service, we're keeping a close eye to ensure there are no further interruptions. Thank you for your patience, we'll update once Google provides the all clear.
Posted Jul 17, 2018 - 19:58 UTC
Identified
Our hosting provider Google App Engine is experiencing an outage and have indicated they will have an update by 1pm pacific. We'll update you as we know more, thank you for your patience and understanding.

Here's a direct link to their status page:
https://status.cloud.google.com/
Posted Jul 17, 2018 - 19:45 UTC
Investigating
An outage is causing Small Improvements to be inaccessible to all customers on our [EU/US] servers. We’re investigating.
Posted Jul 17, 2018 - 19:25 UTC
This incident affected: Application (American Servers, European Servers) and Website.