System Wide Outage
Incident Report for Small Improvements
Resolved
Our hosting provider Google has indicated that the outage is now fully resolved.

Please reach out to our support team at support@small-improvements.com with any questions.
Posted Apr 08, 2020 - 15:34 UTC
Update
Our cloud hosting provider Google is experiencing difficulties which is causing some customers to encounter trouble loading all parts of the app properly.

You can read more about this incident here:
https://status.cloud.google.com/incident/zall/20005

We'll update this page as we have more news.
Posted Apr 08, 2020 - 14:47 UTC
Monitoring
Service is available for customers and we're continuing to monitor the situation.
Posted Apr 08, 2020 - 14:43 UTC
Investigating
A system-wide outage is causing Small Improvements to be inaccessible. We’re investigating.
Posted Apr 08, 2020 - 14:39 UTC
This incident affected: Application (American Servers, European Servers).