Partial Application Failure on US servers

Incident Report for Small Improvements

Resolved

This incident has been resolved
Posted Apr 19, 2024 - 19:21 UTC

Investigating

We are currently investigating interruptions to our service infrastructure which can affect your experience accessing the application.
Posted Apr 19, 2024 - 18:19 UTC
This incident affected: Application (American Servers).