Outage
Incident Report for Small Improvements
Postmortem

The Small Improvements application was unavailable between 11:40am and 12:40pm Pacific time. All requests during this timeframe timed out, making it impossible to navigate the application or even save feedback. We’re very sorry about this disruption to our customers’ productivity.

We’re hosting our application in the Google Cloud, meaning we rent servers and database space at Google. Incidents like these are very rare as the infrastructure is very robust, but sadly sometimes downtime does happen.

You can see more details about Google Cloud's status here: https://status.cloud.google.com/

We’re investigating what exactly happened, as of now it looks like the entire database connection from our application servers to the database was broken. Once Google can provide a definitive response we’ll update the page below.

https://www.small-improvements.com/postmortem-15-02-2018/

Kind regards,

Per and the Small Improvements Team

Posted Feb 15, 2018 - 21:06 UTC

Resolved
The application is now fully accessible, and we'll continue to monitor. Please reach out to support@small-improvements.com for further help and questions.
Posted Feb 15, 2018 - 20:40 UTC
Update
A system-wide outage is causing Small Improvements to be inaccessible. We’re investigating.
Posted Feb 15, 2018 - 20:22 UTC
Investigating
We're seeing internal service errors when accessing the application and our team is investigating.
Posted Feb 15, 2018 - 19:52 UTC