Website is inaccessible
Incident Report for Small Improvements
Resolved
A loadbalancer at our hoster was blocking our traffic. Thanks to their admin team, the issue was resolved.
Posted Feb 21, 2018 - 13:13 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Feb 21, 2018 - 13:07 UTC
Investigating
An outage is causing our homepage, including our pricing page and invoice request functionality, to be inaccessible. We’re investigating. In the meantime, please use https://www.small-improvements.com/login to access your Small Improvements instance.
Posted Feb 21, 2018 - 12:21 UTC