Google Cloud incident causing intermittent errors for some users
Incident Report for Small Improvements
Resolved
Our cloud hosting provider Google has indicated that the degraded performance has been resolved:
https://status.cloud.google.com/incident/storage/18005

Google is conducting an internal investigation of this issue and make appropriate improvements to Google systems to help prevent or minimize future recurrence. The Small Improvements team apologizes for the inconvenience and impact on our customers.

For questions please reach out to support@small-improvements.com
Posted Dec 21, 2018 - 20:19 UTC
Update
We are continuing to work on a fix for this issue.
Posted Dec 21, 2018 - 17:28 UTC
Identified
Our cloud hosting provider Google is experiencing difficulties which is causing some customers to encounter trouble loading all parts of the app properly.

You can read more about this incident here:
https://status.cloud.google.com/incident/storage/18005

Logging out and back in or refreshing your screen could help resolve any errors you encounter. We'll update this page as we have more news.
Posted Dec 21, 2018 - 17:23 UTC
This incident affected: Application (American Servers, European Servers).